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1 Introduction  
The present document is the Design Document for the ADM-Aeolus Level-2B re-processor (L2B-RP).  
The re-processor is the version of the Level-2B (L2B) processor that will be integrated within the 
Aeolus Long-Term Archive (LTA), and will be interfaced to the ThinLayer.  By contrast, the operational 
L2B processor will be interfaced to and integrated within the data assimilation system of the Level-2B 
Meteorological Processing Facility (L2B-MetPF) - this responsibility has been assigned to the 
European Centre for Medium Range Weather Forecasts (ECMWF). 

This document describes the high level software design of the L2B re-processor, following closely the 
structure of the corresponding Design Document for the L2A processor. Chapter 2 contains the list of 
applicable and referenced documents, chapter 3 a list of acronyms. Chapter 4 gives a system design 
overview and chapter 5 describes the components. Chapter 6 shall contain the requirements to design 
components traceability matrix in the next update of the present document.  

Apart from interfacing considerations, the L2B re-processor and operational processor use the same 
source code. 
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2 Applicable & Reference Documents 

2.1 Applicable Documents 
[AD 1] ECSS Space Engineering, Software Part 2: Document requirements definitions, 31/03/2005, 
ECSS-E-40 Part 2B  

2.2 Reference Documents 
[RD 1] Aeolus Level 1b Processor Architectural Design Document, Issue 3/3, 02/10/2006, ADM-DD-
52-1388 

[RD 2] Aeolus Level 2B Processor External Interface Control Document, Version 1.1, 23/02/2007, 
AE-IF-ECMWF-L2BP-002 

[RD 3] Aeolus Level-2B Processor Software User’s Manual, Version 1.3, 23/02/2007, ADM-MA-
ECMWF-L2B-001 

[RD 4] PDS-IPF ICD Generic Interface Guideline, Issue 2.2, 02/08/2006, ESA-ID-ACS-GS-0001 

[RD 5] ADM-Aeolus Level-2B Algorithm Theoretical Base Document (Mathematical Description of the 
Aeolus Level-2B Processor), Version 2.1, 23/02/2007,  AE-TN-ECMWF-L2BP-0023 

[RD 6] L1B & E2S Input/Output Data Definition Interface Control Document, Issue 3.2, Jan 2007, 
ADM-IC-52-1666 

[RD 7] ADM-Aeolus Level-2B/2C Processor Input/Output Data Definitions Interface Control 
Document, Version 1.3, 23/02/2007, ADM-IF-ECMWF-L2BP-001 

[RD 8] Aeolus L1bP Report Generator Component Detailed Design, Issue 1.2, 26/09/2005, ADM-DD-
52-2257 
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3 Terms, Definitions and Abbreviated Terms 

3.1 Abbreviated Terms 
ACMF  ADM Calibration and Monitoring Facility 

ADM-Aeolus Atmospheric Dynamics Mission: Aeolus keeper of the winds 

APF  ADM Processing Facility 

CLI  Command Line Interface 

ECMWF European Centre for Medium-Range Weather Forecasts 

FFC  Feature Finder Component 

HLOS  Horizontal Line-of-Sight (wind component) 

HMI  Human Machine Interface 

ICD  Interface Control Document  

L1bP  Level 1b Processor 

L2aP  Level 2a Processor 

L2B  Level 2B 

L2B-RP  Level 2B Re-Processor 

LTA  Long Term Archive 

MDA  McDonald Dettwiler & Associates 

MJD  Modified Julian Date 

PDS  Payload Data Segment 

RG  Report Generator 

SCA  Standard Correct Algorithm 

SCL  Scene Classification 

TL  Thin Layer 

UTC  Universal Time Coordinate 

WP   Work Package 
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4 Software Design Overview 

4.1 System Context 
The relationship between the ADM-Aeolus L2B Re-Processor Workstation and the Aeolus Payload 
Data Segment is shown below 

...

 Aeolus L2a
 Processing
 Workstation

ACMF APF LTA

L2aP L2aP HMI

Payload Data Segment Thin Layer

 

Figure 1: Aeolus L2BP System Context 

The PDS for the Aeolus mission is composed of several components. The interface between those 
components is the Thin Layer. The TL is responsible for collecting from other PDS components all 
data needed for the L2BP to process a JobOrder. After completion of a JobOrder it collects all the data 
produced by the L2BP to provide these to other components. The L2B-RP thus interfaces only with the 
TL. 

For testing purposes during the development of the L2B-RP, a Command Line Interface was 
constructed, that operates outside the PDS but re-uses the JobOrder aspect of the TL in order to 
specify processor inputs and arguments.  The CLI invocation of the L2B-RP is also suitable for use in 
a general scientific environment. 

 

4.2 External Interfaces 
The interface between the L2B-RP and the TL may be divided into two groups of files: 

• Control and Status: JobOrder, Product Report and List, Logging etc.  

• Data Flow: These are the L1b input product files as well as the L2B output product files, 
auxiliary calibration and meteorological data files, etc. 

For more information see [RD 2]. 

Aeolus L2B 
ReProcessing 
Workstation 

 

L2B-RP 

CLI 

(optional) 
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5 SoftwareDesign 

5.1 General 
By the time the development for the L2B-RP started, a first operational version of the Aeolus L1bP 
was already released, and some fundamental design decisions for the L1bP were carried over to the 
L2B-RP (see [RD 1] and [RD 3]).  In particular, 

• Main components are accompanied by a test directory, containing a stand alone 
executable demonstrating proper functionality of the component.  

  

5.2 Overall Architecture 
The source tree consists of several subdirectories: 

• main Principal L2B processor sources  

 

• Matlab_Tools directory for viewing tools (only usable with the Matlab package) 

• Scripts directory that holds compilation and installation scripts, and the Report Generator 
script 

• Test holding test scripts and expected outputs 

In addition, other sub-directories contain source code related to sub-components of the L2B-RP. 

 

5.3 Software Components Design - General 

 
At the highest level the L2B-RP software package is split into two major components: the L2BP and 
the Report Generator.  As mentioned above, these can be invoked through the TL or through a CLI 
(unix/linux shell). 

 

5.3.1 CLI 

The CLI component is a command line interface that enables an operator to start/stop the L2B-RP and 
the Report Generator components without needing the ThinLayer. It requires the operator to 
prepare/modify a JobOrder file and to place auxiliary data files in corresponding directories. It can be 
invoked following installation of the L2B-RP and the Report Generator.  

 

5.3.2 L2B-RP 

The L2B-RP is a stand alone Fortan-90 software package that takes an L1b product as input and 
processes the data to an L2B output product. A description of the input and output data product 
contents may be found in [RD 6] and [RD 7] and the algorithms used to process the data are 
described in [RD 5].  

The L2B-RP component contains the scientific processing algorithms unique to the L2B processor. It 
is split into the input screening subcomponent, the scene classification subcomponent, the HLOS 
retrieval subcomponent, and the L2B_primary component with the L2B main executable. 
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5.3.3 Report Generator 

The report generator uses the log file provided by the TL or the CLI to produce a product report and a 
product list. The format of the output of the Report Generator is described in [RD 4]. It is the same for 
the ADM-Aeolus processors of all levels. 

In the current version this report generator is a small python script shared with the L2aP developers.  

5.3.4 Sub-components 

The L2B-RP sub-components are a collection of diverse functionalities, such as reading or writing of 
data. The source tree has the following sub-directories for the principal sub-components: 

• AMD_file_handling: Read and store auxiliary meteorological input data. 

• Classification: Perform scene classification. 

• HLOS_retrieval: Perform HLOS wind retrievals for the Mie and Rayleigh channels. 

• InputScreening: Perform screening of input data. 

• L1B_file_handling: Read and store level 1b input product 

• L2BC_file_handling: Store and write level 2b output product (and extension too level 2c output 
product) 

• support: Provide support functionality, including a basic logging mechanism and Date/Time 
handling 

• xml_module: Provide functionality to deal with big - little endian transformation and xml data 
reading. 
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5.3.5 Component Interaction - Overview 

HMI

Data Interface

L2aP

Input:
- L1B Product
- AUX_CAL_L2
- AUX_CLM_L2
- AUX_MET_12
- AUX_PAR_2A

Output:
- L2A Product
- Internal Log

Control & Status 
Interface

RG

Data Interface

- Start/Stop Message

- Status Messages
- Exit Code

Input:
- Internal Log

Control Interface

- Start Message

Data Interface

Output:
- Product Report

 

Figure 2 Component Interaction.  This figure is copied from the L2A Design Document and 
needs further editing: i) AUX_PAR_2A to be replaced by AUX_RBC_L2 and AUX_PAR_2B, ii) 

L2A Product to be replaced by L2B Product. 

Figure 2 shows the high level communication between the two executables of the L2B-RP delivery. 
Information on the input/output files may be found in [RD 7]. 

5.4 Software Components Design - Specific Aspects 
5.4.1  CLI Components 

The CLI merely enables command-line invocation of the L2B-RP and Report Generator.  It contains no 
specific sub-components. It is assumed that all editing of JobOrder files in a general scientific 
environment will be done with the preferred text editor of the user. 

 

5.4.2 L2BP Components 

The components L2B_Processor and l2bp_module may be found in the ./main sub-directory of the 
L2BP_Source tree. 

 

5.4.2.1 L2B_Processor 

This component is responsible for the main processing control within the L2B-RP. It starts and calls all 
the other components and controls data flow between them. In the current version it 

• Checks arguments of the call to the L2B-RP 

• Reads the JobOrder file 

• Extracts input files from the JobOrder file 

• Evaluates the header of the L1b input product 

L2B-RP CLI 
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• Initializes the L2B Processor object and calls the processing method. 

<Component Identifier> L2B_Processor 

<Type> executable 

<Purpose> Main frame for the L2B-RP executable. 

<Function> Read JobOrder file, extract input filenames, check existence of input files, log input 
filenames, trigger reading of level 1b input file, evaluate level 1b header information, trigger data 
processing in l2bp_module/L2BP_primary. 

<Subordinates> l2bp_module 

<Dependencies> None 

<Interfaces>  

Control interface: this component is the main component it controls, initializes and terminates the L2B-
RP. 

Data flow interface: the external interface is the JobOrder file as described in [RD 4]. The internal data 
interface to the l2bp-module component is a structure holding the level 1b data, see <Data>. 

<Resources> None 

<References> [RD 4], [RD 6] 

<Data> The main internal data structure is a collection of Fortran-90 data structures containing the 
level1b data. The collection of Fortran-90 data structures maps the structure that is defined in [RD 6]. 

 

5.4.2.2 l2bp_module 

The l2bp_module component runs the L2B data processing. For the current version, it evaluates the 
L1b header information and calls the component L2BP_primary (see Error! Reference source not 
found.). 

<Component Identifier> l2bp_module 

<Type> non-executable 

<Purpose> Organize data processing into appropriate loops. 

<Function> Organize level1b data into different subsets that are then processed by the 
input_screening and hlos_retrieval components. Trigger writing of level 2b output product. 

<Subordinates> input_screening, hlos_retrieval  

<Dependencies> None 

<Interfaces>  

Control interface: this component controls and initializes the input_screening and hlos_retrieval 
components. 

Data flow interface: The main internal interfaces are structures holding the level 1b and level 2b data, 
see <Data>. 

<Resources> None 

<References> [RD 6], [RD 7] 

<Data>  

Level 1b: A collection of Fortran-90 data structures containing the level 1b data. The collection of 
Fortran-90 data structures maps the structure that is defined in [RD 6]. 

Level 2b: A collection of Fortran-90 data structures containing the level 2b data. The collection of 
Fortran-90 data structures maps the structure that is defined in [RD 7]. 
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5.4.2.3 FFC 

This component is a stub for a future Feature Finder algorithm, it may be found in the TBD directory of 
the L2BP_Source tree. 

<Component Identifier> FFC 

<Type> non-executable 

<Purpose>  

<Function>  

<Subordinates> Gen 

<Dependencies>  

<Interfaces>  

<Resources>  

<References>  

<Data>  

 

5.4.2.4 SCL 

This component is a stub for a future Scene Classification algorithm, it may be found in the TBD 
directory of the L2BP_Source tree. 

<Component Identifier> SCL 

<Type> non-executable 

<Purpose>  

<Function>  

<Subordinates> Gen 

<Dependencies>  

<Interfaces>  

<Resources>  

<References>  

<Data>  

 

 

5.4.3 Report Generator Component 

 

<Component Identifier> RG 

<Type> Python executable 

<Purpose> Generate the product report file as specified in see <References>. 

List of requirements: TBD 

<Function> Open and read internal logfile, write product report file 

<Subordinates> None 

<Dependencies> L2B_Processor needs to be run before the RG, to generate the log file that is input 
to the RG. 

<Interfaces> Internal log file using syntax as described in see <References> 
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<Resources> None 

<References> [RD 4] 

<Data> None 

 

5.4.4 Sub-components 
5.4.4.1 AMD_file_handling 

<Component Identifier> AMD_file_handling 

<Type> non-executable  

<Purpose> Provide functionality to read and store the auxiliary meteorological input data 

<Function> Open input file, read data, store data 

<Subordinates> TBD 

<Dependencies> None 

<Interfaces> The internal interfaces are Fortran-90 data structures holding the auxiliary 
meteorological input data. 

<Resources> None 

<References> [RD 7] 

<Data> A collection of Fortran-90 data structures containing the auxiliary data. The collection of 
Fortran-90 data structures map the structures defined in [RD 7]. 

 

5.4.4.2 Classification 

<Component Identifier> Classification 

<Type> non-executable  

<Purpose> Provide functionality to classify L1B measurement range-bins 

<Function> Derive a classification map and corresponding weights. 

<Subordinates> TBD 

<Dependencies> None 

<Interfaces> TBD 

<Resources> None 

<References> None 

<Data> Two Fortran-90 data structures containing classification map and corresponding weights 

 

5.4.4.3 HLOS_retrieval 

<Component Identifier> HLOS_retrieval 

<Type> non-executable  

<Purpose> Compute HLOS wind component retrievals 

<Function> Perform the HLOS retrieval algorithms specified in the ATBD [RD 5] 

<Subordinates> None 

<Dependencies> None 

<Interfaces> None 

<Resources> None 
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<References> None 

<Data> None 

 

5.4.4.4 DataStructures 

This sub-component holds some general definitions on data types and other variables. It may be 
found in the ./DataStructures/ directory of the L2BP_Source tree. 

<Component Identifier> DataStructures 

<Type> non-executable  

<Purpose> Provide different definitions 

<Function> No functionality just definitions 

<Subordinates> None 

<Dependencies> None 

<Interfaces> None 

<Resources> None 

<References> None 

<Data> None 

 

5.4.4.5 L1B_file_handling 

This component is responsible for reading and storing the level 1b input product. They may be found 
in the ./L1B_file_handling directory of the L2BP_Source tree. 

<Component Identifier> L1B_file_handling 

<Type> non-executable  

<Purpose> Provide functionality to read and store level 1b data. 

<Function> Open file, read data, store data. 

<Subordinates> Gen, Log 

<Dependencies> None 

<Interfaces> 

Data flow interface: The main internal interface is a structure holding the level 1b data, see <Data>. 

<Resources> None 

<References> [RD 6] 

<Data>  

Level 1b: A collection of Fortran-90 data structures containing the level1b data. The collection of 
Fortran-90 data structures maps the structure that is defined in [RD 6]. 

 

 

 

5.4.4.6 L2BC_file_handling 

This component controls and holds subcomponents for the header information and the different data 
sets of the L2B product, and its extension the L2C product. It writes a binary L2B/L2C data product. 
For the current version this component is directly controlled by the L2B_Processor component. 

<Component Identifier> L2BC_file_handling 
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<Type> non-executable  

<Purpose> Provide functionality to store and write data 

<Function> Store data, open file, and write data. 

<Subordinates> Gen, Log 

<Dependencies> None 

<Interfaces> 

Data flow interface: The main internal interface is a structure holding the level 2b/2c data, see <Data>. 

<Resources> None 

<References> [RD 7] 

<Data>  

Level 2B/C: A collection of Fortran-90 datastructures containing the level 2b/c data. The collection of 
Fortran-90 data structures maps the structure that is defined in [RD 7]. 

 

5.4.4.7 Logging 

<Component Identifier> Log 

<Type> non-executable  

<Purpose> Provide functionality to write logging messages to a log file 

<Function> Takes message and its type as input and writes the message to the log file using the 
format specified in [RD 4] 

<Subordinates> Gen 

<Dependencies> None 

<Interfaces> 

Data flow interface: Values holding message and its type 

<Resources> None 

<References> [RD 4] 

<Data> TBD 

 

5.4.4.8 SysDep 

<Component Identifier> SD 

<Type> non-executable  

<Purpose> Provide access to system calls 

<Function> Wraps system calls in C++ methods.  

<Subordinates> Gen 

<Dependencies> None 

<Interfaces> TBD 

<Resources> None 

<References> None 

<Data> TBD 
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5.4.4.9 xml_module 

This component is responsible for reading an XML file. It may be found in the ./xml_module directory 
of the L2BP_Source tree. 

<Component Identifier> xml_module 

<Type> non-executable  

<Purpose> Provide functionality to swap bytes and read xml data files. 

<Function> Upon call either swap bytes or read specified file  

<Subordinates> Gen 

<Dependencies> None 

<Interfaces> TBD 

<Resources> libxml 

<References> None 

<Data> TBD 
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6 Requirements to Design Components Traceability 
TBD 


